Navigaweb.net

Migliori siti, programmi e applicazioni su Navigaweb.net

Programmi Guide PC Tecnologia Sicurezza Windows Rete iPhone Android Facebook Immagini Musica Giochi

Formule Excel per contare numeri e celle (CONTA e SOMMA)

Pubblicato il: 20 marzo 2015 Aggiornato il:
Mini guida alle formule Excel CONTA e SOMMA, per velocizzare i calcoli, anche condizionali e con criteri di selezione
funzione conta.se Le formule di Excel possono fare davvero la differenza nei fogli di calcolo e aiutarci a gestire i numeri in modo automatico e semplice, risparmiando molto tempo con la calcolatrice e con i conti.
In questo articolo vediamo alcune formule avanzate di conteggio in Excel e in LibreOffice Calc (anche se su Excel è tutto molto più semplice), che possono essere utilizzati in qualsiasi foglio di calcolo, lungo quanto si vuole, fatto di numeri o valori disposti anche in diverse colonne.

LEGGI ANCHE: 4 operazioni da saper fare lavorando con Word e Excel

CONTA
La funzione CONTA serve a contare il numero di celle in un intervallo.
La Conta funziona solo per contare il numero di celle contenenti numeri, date, operatori logici o un testo che rappresenta un numero.
In LibreOffice questa funzione si chiama CONTA.NUMERI.
Se si vogliono includere anche celle con testo nel conteggio, si utilizza la funzione CONTA.VALORI mentre per contare le celle vuote in un intervallo, si può utilizzare CONTA.VUOTE.
Per esempio, si può contare il numero di celle con numeri scrivendo la funzione
=CONTA(A1:F2)
Tra parentesi si scrive l'intervallo di celle da contare.

CONTA.SE è simile alla CONTA normale, ma condizionale, dove cioè si può impostare un criterio di selezione per la conta delle celle.
Per esempio, in una lista di nomi si può contare quanti si chiamano Claudio scrivendo:
=CONTA.SE(A1:A100;"claudio") o =CONTA.SE(A:A;"claudio")
È possibile utilizzare questo metodo anche, ad esempio, per sapere quanti studenti hanno preso un voto superiore a 24, scrivendo ">24" come criterio di selezione.
È inoltre possibile, su Excel, utilizzare una cella come criterio di conteggio, ad esempio =CONTA.SE(A:A;"B1") con in B1 una parola che si vuole contare nella colonna A.

CONTA.PIÙ.SE
Mentre CONTASE consente di contare celle base di un unico criterio, CONTA.PIÙ.SE serve quando ci sono più condizioni o criteri da utilizzare nella conta, in più intervalli.
La sintassi è la seguente: =CONTA.PIÙ.SE(Intervallo-celle,“criterio1”, Intervallo2,"criterio2")
In LibreOffice si deve usare il ; invece della , .

LEGGI ANCHE: 6 Funzioni Excel più utili per filtrare i dati e vedere grafici

SOMMA.SE
LA Somma è la funzione per sommare i numeri nelle celle selezionate, mettendo una condizione.
Il SOMMA.SE è la somma, con un criterio di selezione, per contare non tutti i valori nel range ma solo quelli che rispettano un certo criterio.
Per esempio, avendo una tabella con due colonne, una con i nomi e l'altra con i soldi guadagnati con varie attività, possiamo scrivere:
=SOMMA(A:A, "Claudio", B:B) per sommare i soldi guadagnati (presi dalla colonna B) da Claudio (estratti dalla colonna A).
Come le altre formule, in LibreOFfice bisogna usare il ; ed è un po' meno facile districarsi.

SOMMA.PIÙ.SE
Se aggiungiamo all'esempio sopra una terza colonna, ad esempio con le città di residenza delle persone, possiamo scrivere: =SUMIFS(B:B, A:A, “Claudio”, C:C, “ROMA”)
In questo caso si aggiunge quindi, alla funzione, la città dove sono stati guadagnati i soldi da Claudio (immaginando che Claudio ha lavorato in più città guadagnando cifre diverse).

La funzione SOMMA è sicuramente più familiare rispetto la funzione CONTA che è invece molto utile per fare statistiche e conteggi in tabelle molto grandi.
Con i SE e con i PIU si possono aggiungere facilmente criteri di selezione, per estrarre dati dalle tabelle.
Ci sono anche altre formule legate alla SOMMA, che è possibile utilizzare tramite lo strumento di creazione guidata.
Le formule possono anche essere combinati con funzioni logiche per creare formule condizionali (vedi qui)
In queste pagine web ulteriori guide per le funzioni e le formule su Excel.

LEGGI ANCHE: Diventare bravi con Excel sui fogli di calcolo (anche con LibreOffice e Google Drive)

Scrivi un commento

Per commentare, si può usare un account Google / Gmail.
Se vi piace e volete ringraziare, condividete! (senza commento)